$re = '/^(?=(.*[0-9]))(?=.*[\!@#$%^&*()\\\\[\]{}\-_+=~`|:;"\'<>,.\/?])(?=.*[a-z])(?=(.*[A-Z]))(?=(.*)).{8,}$/m';
$str = 'pass
password
pas$word123
pas$word12311111
paSWord@111
mYpa$$word123
// You can show origina post on albertcolom.com/blog';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);