using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:\d+|A)(?:\.\d+)*\.\B";
string input = @"A.8. 8.4.2.4.1.2. 9.1. 9. 10.0.1.1. 9 0.1 100. 100.5. A.500";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}