$re = '/(?=((\b\w+\b\s){2}))/m';
$str = 'one two three four ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);