package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(*([0-9]{3})\D*([0-9]{3})\D*([0-9]{4})`)
var str = `(310) 808-5243
415.846.1688
7203189049
3238886200
323.888.6237
323-888-6209
323/888.6202
3237078576
(323) 216-2201
323.960.3100
7274554538
727-214-5862
727/455.5955
424-209-0017
305-242-4044
(305) 245-1641
8184813655
909.259.5674
(469) 438-2843
323/216.9079
323/953.3340
916-588-8042
7273247922
310.800.3391
4157978909
727.639.0277
323.386.5239
213.840.1971
4242007177
323/816.9831
310-404-5928
323-492-7681
323-833-8515
323-386-5428
(323) 244-3832
310/808.8752
323.855.0394
214/900.6004
727-687-3465
(646) 879-9137
3239533396
323-816-9613
323/816.7010
323.273.5174
323-386-5700
323.386.5699
818-859-4757
727-452-5725
(323) 608-1510
4088294846
323-997-1080
(323) 855-0338
323.717.8673
323/419.6398
3235950799
323-240-2739
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}