$re = '/(http:\/\/|https:\/\/)?(www.)?(vk\.com|vkontakte\.ru)\/(id(\d{9})|[a-zA-Z0-9_.]+)/';
$str = 'https://vk.com/sasha_dream/
https://vk.com/id414741474147
https://vk.com/id4147';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);