re = /(?<=[(.,\s])(\d+)(?=[,.)])/
str = '
CDS join(1200..1401,1550..1613,1900..2010,2200..2250,
2300..2660,2800..2999,3100..3333)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end