$re = '/<([a-z]+)\ ?([a-z]+=\".*?\"\ ?)?>([.\n\sa-z]*)(<\/\1>)?/';
$str = '<lolz>
<>
<meh crap="shit">
<bullshit turds="dick" crap="lolz" meh="turds">
random
random
</bullshit>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);