use strict;
my $str = 'Galtronics, 62-29-03 - Swivel Mounting Bracket For PEAR Panel Antennas Wall & Pole Installation
Microlab/FXR, D2-83FE - 2-way Splitter, 617-5925Mhz
Microlab, D2-J12 - 698-2700 2-Way Low PIM Splitter
Microlab, JA-05TN - 0.141in Low PIM Cable
JMA Wireless, JMA-4M4F-14S-3 - Jumper, 4.3‐10 Male ‐ 4.3‐10 Female, 14S cable, 3 feet; for diplexer output
Galtronics, PEAR M5277i - 4.3-10 DIN - Directional Dual Polarized MIMO Outdoor/In-Building Antenna, Port 1 and 2: 698-2700 MHz, 2x 4.3-10 DIN Female with Cable - P/N: 02130261-05277
JMA Wireless, SX08FRO128-01 - 8 Port Directional MIMO Venue Panel
JMA Wireless, TRL7S8A19AWAS - RU Quad Band 31dBm AC Powered WDM SMF SC-APC
JMA Wireless, TRLOPK-4 - Outdoor Protection Kit IP66 for Low power RUs 4.3
JMA Wireless T7S8SC8A19AWEWVAS- RU 5 BAND 700LTE-SMR800 COMMER AMPS850-PCS1900-AWS3 VHP AC POWER WDM SMF SC
JMA Wireless, TSC2W-U - 2-way Splitter/Combiner 698-2690MHz
No Name, Wooden Crate - 2 Band Mount 13 1/2 x 17
No Name, Wooden Crate - 6 Band Mount 15 x 17
JMA Wireless, UPL-DM-12 - 7-16 DIN Male Connector, 1/2" Plenum
JMA Wireless TNF-8A-UL/R Teko Notch Filter: pass band AMPS850-UL, stop band PS800-DL
Microlab DN-44FE Low PIM 698-2700MHz 4.8dB Coupler (4.3-10 F)';
my $regex = qr/(^[A-Za-z \/]+[ ,])( [A-Z0-9- ]+)[ ][-][ ]\b[0-9-]{3,}\b|(^[A-Za-z \/]+[ ,])( [A-Z0-9- ]+)[ ][-][ ]|(^[A-Za-z \/]+[ ,])[A-Z0-9-\/]+[ ]|(^[A-Za-z \/]+[ ,])( [A-Z]+ [0-9A-Za-z]+)[ ][-][ ]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}