$re = '/ab{3}c/m';
$str = 'abc
abbc
abbbc
abbbbc
abbbbbc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);