using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"__t\(\s*[""'](.*)[""']\s*(.*)\)";
string input = @"alert( __t( 'Minu argumendid {0}, {1}, {2}, {3', 'tere', 'ants','lahe', 'midagi' ) );
alert(__t( 'Mingi tekst') );
alert(__t(""Mingi tekst"") );
alert(__t( var_name ) );
__t('Mingi tekst')
function name() {
console.log(__t('sdfsdf'));
}
true ? __t( 'Mingi tekst' ) : __t( 'Teine tekst' );
$(el).html( __t( 'Tekst' ) + variable + '__t( 'Tekst' ) );
function( [ __t( 'tekst' ), __t( 'tekst2' ) ] );";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}