$re = '/[-+]?[0-9]*\.?[0-9]+/';
$str = '121212.51231
+5.2342
.545
+.23423
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);