$re = '/(<label class="cf4all_button cf4all_no_color_btn " for="cf4all_input_+[0-9_]+_">)(.*?)(?:<\/label>)/';
$str = '<span class="cf4all_error_msg" style="display: none">Пожалуйста, выберите опцию! </span>
<div class="inline-control-group">
<input type="radio" value="1909" id="cf4all_input_13927_22_" class="cf4all_radio" name="customProductData[2521][122][13927][customsforall_option]"><label>XXS </label>
</div>
<div class="inline-control-group">
<input type="radio" value="1910" id="cf4all_input_13927_3_" class="cf4all_radio" name="customProductData[2521][122][13927][customsforall_option]"><label >XS </label>
</div>
<div class="inline-control-group">
<input type="radio" value="1911" id="cf4all_input_13927_1_" class="cf4all_radio" name="customProductData[2521][122][13927][customsforall_option]"><label class="cf4all_button cf4all_no_color_btn " for="cf4all_input_13927_1_">S </label>
</div>
<div class="inline-control-group">
<input type="radio" value="1912" id="cf4all_input_13927_2_" class="cf4all_radio" name="customProductData[2521][122][13927][customsforall_option]"><label class="cf4all_button cf4all_no_color_btn " for="cf4all_input_13927_2_">M </label>
</div>
<div class="inline-control-group">
<input type="radio" value="1913" id="cf4all_input_13927_9_" class="cf4all_radio" name="customProductData[2521][122][13927][customsforall_option]"><label class="cf4all_button cf4all_no_color_btn " for="cf4all_input_13927_9_">L </label>
</div>
<div class="inline-control-group">
<input type="radio" value="1914" id="cf4all_input_13927_12_" class="cf4all_radio" name="customProductData[2521][122][13927][customsforall_option]"><label class="cf4all_button cf4all_no_color_btn " for="cf4all_input_13927_12_">XL </label>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);