const regex = /(?<=\<span\>).*?(?=\<\/span\>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\<span\\>).*?(?=\\<\\\/span\\>)', 'g')
const str = `<meta http-equiv=\\"Content-Type\\" content=\\"text/html; charset=utf-8\\"><div dir=\\"ltr\\"><p class=\\"MsoNormal\\" style=\\"margin:0in 0in 12pt;font-size:11pt;font-family:Calibri,sans-serif\\"><span style=\\"font-family:"Times New Roman",serif\\">Kính gửi Quý khách: Bùi Thị Nở<br>\\r\\n<br>\\r\\nCông ty Cổ phần INSMART/ Công ty Bảo hiểm Bưu điện Thăng Long trân trọng thông\\r\\nbáo: Hồ sơ yêu cầu bồi thường của Quý khách đã được tiếp nhận với nội dung chi\\r\\ntiết.</span></p>\\r\\n\\r\\n<table class=\\"gmail-MsoNormalTable\\" border=\\"1\\" cellspacing=\\"0\\" cellpadding=\\"0\\">\\r\\n <tbody><tr>\\r\\n <td width=\\"15%\\" nowrap=\\"\\" style=\\"width:15%;padding:3.75pt\\">\\r\\n <p class=\\"MsoNormal\\" align=\\"center\\" style=\\"text-align:center;margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><strong>Số hồ sơ</strong> </p>\\r\\n </td>\\r\\n <td width=\\"34%\\" nowrap=\\"\\" style=\\"width:34%;padding:3.75pt\\">\\r\\n <p class=\\"MsoNormal\\" align=\\"center\\" style=\\"text-align:center;margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><strong>Họ và tên NĐBH</strong> </p>\\r\\n </td>\\r\\n <td width=\\"33%\\" nowrap=\\"\\" style=\\"width:33%;padding:3.75pt\\">\\r\\n <p class=\\"MsoNormal\\" align=\\"center\\" style=\\"text-align:center;margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><strong>Họ và tên nhân viên</strong> </p>\\r\\n </td>\\r\\n <td width=\\"28%\\" nowrap=\\"\\" style=\\"width:28%;padding:3.75pt\\">\\r\\n <p class=\\"MsoNormal\\" align=\\"center\\" style=\\"text-align:center;margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><strong>Số tiền yêu cầu BT</strong> </p>\\r\\n </td>\\r\\n <td width=\\"15%\\" nowrap=\\"\\" style=\\"width:15%;padding:3.75pt\\">\\r\\n <p class=\\"MsoNormal\\" align=\\"center\\" style=\\"text-align:center;margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><strong>Ngày nhận</strong> </p>\\r\\n </td>\\r\\n </tr>\\r\\n <tr>\\r\\n <td style=\\"padding:3.75pt\\">\\r\\n <p class=\\"MsoNormal\\" align=\\"center\\" style=\\"text-align:center;margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><span style=\\"font-family:"Times New Roman",serif\\">1959491</span> </p>\\r\\n </td>\\r\\n <td style=\\"padding:3.75pt\\">\\r\\n <p class=\\"MsoNormal\\" align=\\"center\\" style=\\"text-align:center;margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><span style=\\"font-family:"Times New Roman",serif\\">Bùi\\r\\n Thị Nở</span> </p>\\r\\n </td>\\r\\n <td style=\\"padding:3.75pt\\">\\r\\n <p class=\\"MsoNormal\\" align=\\"center\\" style=\\"text-align:center;margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><span style=\\"font-family:"Times New Roman",serif\\">Bùi\\r\\n Thị Nở</span> </p>\\r\\n </td>\\r\\n <td style=\\"padding:3.75pt\\">\\r\\n <p class=\\"MsoNormal\\" align=\\"center\\" style=\\"text-align:center;margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><span style=\\"font-family:"Times New Roman",serif\\">298,100VND</span> </p>\\r\\n </td>\\r\\n <td style=\\"padding:3.75pt\\">\\r\\n <p class=\\"MsoNormal\\" align=\\"center\\" style=\\"text-align:center;margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><span style=\\"font-family:"Times New Roman",serif\\">02/03/2023</span> </p>\\r\\n </td>\\r\\n </tr>\\r\\n</tbody></table>\\r\\n\\r\\n<p class=\\"MsoNormal\\" style=\\"margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><span style=\\"font-family:"Times New Roman",serif\\"><br>\\r\\nĐể đảm bảo quyền lợi bảo hiểm được bồi thường đúng và đầy đủ, Quý khách vui\\r\\nlòng bổ sung các chứng từ theo tài liệu đính kèm email này.<br>\\r\\n<br>\\r\\n<strong><i>Lưu ý:</i></strong> </span></p>\\r\\n\\r\\n<ul type=\\"disc\\" style=\\"margin-bottom:0in\\">\\r\\n <li class=\\"MsoNormal\\" style=\\"margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><span style=\\"font-family:"Times New Roman",serif\\">Sau\\r\\n ngày 20/03/2023, nếu Insmart chưa nhân được thông tin phản hồi của Quý\\r\\n khách, hồ sơ sẽ được giải quyết bồi thường dựa trên chứng từ hiện có.</span></li>\\r\\n <li class=\\"MsoNormal\\" style=\\"margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><span style=\\"font-family:"Times New Roman",serif\\">Chứng\\r\\n từ cung cấp bản scan/bản ảnh phải là bản màu đầy đủ thông tin như bản gốc,\\r\\n Công ty bảo hiểm có quyền yêu cầu đối chiếu trong một số trường hợp cần\\r\\n thiết.</span></li>\\r\\n <li class=\\"MsoNormal\\" style=\\"margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><span style=\\"font-family:"Times New Roman",serif\\">Đối với\\r\\n hồ sơ yêu cầu nộp chứng từ bản gốc, vui lòng in email này gửi cùng hồ sơ.</span></li>\\r\\n</ul>\\r\\n\\r\\n<p class=\\"MsoNormal\\" style=\\"margin:0in;font-size:11pt;font-family:Calibri,sans-serif\\"><span style=\\"font-family:"Times New Roman",serif\\">Trường hợp cần trao đổi thêm, Quý khách vui lòng gọi đến\\r\\nTổng đài phục vụ dành riêng cho khách hàng số <strong><span style=\\"color:red\\">1900\\r\\n636 760</span></strong>; hoặc gửi email theo địa chỉ <a href=\\"mailto:helpdesk.hanoi1@insmart.com.vn\\" style=\\"color:rgb(5,99,193)\\">helpdesk.hanoi1@insmart.com.vn</a>\\r\\n<br>\\r\\n<br>\\r\\nKính chúc quý khách và gia đình luôn mạnh khỏe, hạnh phúc!<br>\\r\\n<br>\\r\\nTrân trọng kính chào!<br>\\r\\n<br>\\r\\n<strong>Công ty Cổ phần INSMART</strong><br>\\r\\nĐịa chỉ: Tầng 25, Ngọc Khánh Plaza, Số 1 Phạm Huy Thông, Phường Ngọc Khánh,\\r\\nQuận Ba Đình, TP Hà Nội<br>\\r\\nCall center: 1900 636 760<br>\\r\\nEmail: <a href=\\"mailto:helpdesk.hanoi1@insmart.com.vn\\" style=\\"color:rgb(5,99,193)\\">helpdesk.hanoi1@insmart.com.vn</a>\\r\\n<br>\\r\\n<br>\\r\\n<i>* Quý khách lưu ý: Đây là email được gửi tự động, Quý khách vui lòng không\\r\\nhồi đáp lại email này.</i><br>\\r\\n<i>* Công ty Cổ Phần Insmart được chỉ định để giải quyết quyền lợi bảo hiểm sức\\r\\nkhỏe của Công ty Bảo hiểm Bưu điện Thăng Long.</i></span></p></div>\\r`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}