#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[^\s])$"
Local $sString = "AAAAAA" & @CRLF & _
"BBBBBB" & @CRLF & _
"CCCCCC" & @CRLF & _
"" & @CRLF & _
"DDDDDD" & @CRLF & _
"EEEEEE" & @CRLF & _
"" & @CRLF & _
"FFFFFF" & @CRLF & _
"GGGGGG" & @CRLF & _
"HHHHHH"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")