re = /\A[\s\S]*?\b\K(?:https?:\/\/\S*\h*\|\h*)*[^\s|][^|\r\n]*\|/
str = ' first text to match |
https://randomsite.com | https://randomurl2.com | text | https://randomsite.com |
https://randomsite.com | https://randomsite.com |'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end