$re = '/\d{4}:\s\d+/';
$str = '2007: 1
1909: 145
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);