$re = '/(?<!\d)\d{2}:\d{2}(?!\d)/';
$str = 'sdhgjhdgsjdf12:34knvxjkvndf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);