using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+ли\w+)";
string input = @"Идейные соображения высшего порядка, а также пост оянное информационно-пропагандистское обеспечение нашей деятельности требуют от нас анализа форм развития.";
RegexOptions options = RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}