const regex = /\w+(?=\|[a-f0-9]+(?:-[a-f0-9]+)+\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+(?=\\|[a-f0-9]+(?:-[a-f0-9]+)+\\b)', 'gm')
const str = `Germany|fbf4cf3c-ebfe-43c8-aaf9-6811bd3488b0`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);