$re = '/prashant\.singh\+07\/04@testunity\.com/m';
$str = 'prashant.singh+07/04@testunity.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);