const regex = /([(\s0-9]+)([lL]\.?)([)\s]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([(\\s0-9]+)([lL]\\.?)([)\\s]+)', 'g')
const str = `2 l.
2l.
2l
cuatro l
lateral
1l.
l.
L.
ls.
Ls.
L
l
(l)
(L)
(ls.)
(Ls.)
(ls)
(Ls)
l.
l.
L
l
3l.
2l.
2l.
4 l.
4l
5L.
lateral
literal
1 litro
1l.
1 l. de agua
1/2 L. de zumo
(l)
1l
l.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}