$re = '~((?:[0-9]+[\+|\-|\*|\/]?)+)~';
$str = 'text 1+1-1*1/1= text';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);