$re = '/.+?(?:(?<![\s.]\p{Lu})[.!?]|$)/s';
$str = 'The National Aeronautics and Space Administration (NASA) is the United States government agency responsible for the civilian space program as well as aeronautics and aerospace research.
President Dwight D. Eisenhower established the National Aeronautics and Space Administration (NASA) in 1958[5] with a distinctly civilian (rather than military) orientation encouraging peaceful applications in space science. The National Aeronautics and Space Act was passed on July 29, 1958, disestablishing NASA\'s predecessor, the National Advisory Committee for Aeronautics (NACA). The new agency became operational on October 1, 1958.[6][7]
Since that time, most U.S. space exploration efforts have been led by NASA, including the Apollo moon-landing missions, the Skylab space station, and later the Space Shuttle. Currently, NASA is supporting the International Space Station and is overseeing the development of the Orion Multi-Purpose Crew Vehicle, the Space Launch System and Commercial Crew vehicles. The agency is also responsible for the Launch Services Program (LSP) which provides oversight of launch operations and countdown management for unmanned NASA launches.
NASA science is focused on better understanding Earth through the Earth Observing System,[8] advancing heliophysics through the efforts of the Science Mission Directorate\'s Heliophysics Research Program,[9] exploring bodies throughout the Solar System with advanced robotic spacecraft missions such as New Horizons,[10] and researching astrophysics topics, such as the Big Bang, through the Great Observatories and associated programs.[11] NASA shares data with various national and international organizations such as from the Greenhouse Gases Observing Satellite.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);