$re = '/(?=(\{(?>[^{}]|(?1))*+\}))/';
$str = 'Hello {#name}! I\'m a {%string|sentence|bit of {?(random == "strange") ? {#random} : "strange"}} text}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);