re = /(?=^.{3,20}$)^[a-zA-Z][a-zA-Z0-9]*[._-]?[a-zA-Z0-9]+$/
str = 'https://regex101.com/r/sJ9qC7/1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end