$re = '/(?<=<[hH]([1-6])>).*?(?=<\/[hH]\1>)/m';
$str = '<body>
<H1>Welcome to my Homepage</H1>
Content is divided into two sections:<br/>
<h2>SQL</h2>
Information about SQL.
<h2>RegEx</h2>
Information about Regular Expressions.
<h3>This is not a valid HTML</h4>
</body>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);