$re = '/<div.*?>\d+<\/div>/';
$str = '<div class="row">123</div>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);