// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"IOCP\.sendVarData\(\s*(\d+)\s*,\s*\(int\)sPmdgData\.MCP_(\w+)\);").unwrap();
let string = "IOCP.sendVarData(1374, (int)sPmdgData.MCP_FPA);
IOCP.sendVarData(100, (int)sPmdgData.MCP_ABC);";
let substitution = "if((int)sPmdgData.MCP_\\2) != T7X_MCP_\\2)\\n{\\n\\tT7X_MCP_\\2 = sPmdgData.MCP_\\2;\\n\\tIOCP.sendVarData(\\1, T7X_MCP_\\2);\\n}\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}