re = /^(?=.*[a-zA-Z])(?=.*\d)(?=.*[!@#$%^&*()_+])[A-Za-z\d!@#$%^&*()_+.]{8,64}$/m
str = '.abc@1234
*abc@1234
abc@1234.
a@b.c1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end