re = /^(?:[a-zA-Z0-9._-]+@[a-zA-Z0-9.-]+.[a-zA-Z]{2,6})?$/m
str = 'abc@gmail.com
asd@sds.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end