#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s(?P<ValueType>\w+)\s(?P<DataType>\w+)?\s?Instance[\.\:](?P<Inheritance>\w+) ?(?P<TagsOrArguments>.+)?"
Local $sString = "Class Instance [notbrowsable]" & @CRLF & _
" Property bool Instance.Archivable" & @CRLF & _
" Property string Instance.ClassName [readonly]" & @CRLF & _
" Property int Instance.DataCost [readonly] [RobloxPlaceSecurity]" & @CRLF & _
" Property string Instance.Name" & @CRLF & _
" Property Object Instance.Parent" & @CRLF & _
" Property bool Instance.RobloxLocked [PluginSecurity]" & @CRLF & _
" Property bool Instance.archivable [hidden]" & @CRLF & _
" Property string Instance.className [deprecated] [readonly]" & @CRLF & _
" Function void Instance:ClearAllChildren()" & @CRLF & _
" Function Instance Instance:Clone()" & @CRLF & _
" Function void Instance:Destroy()" & @CRLF & _
" Function Instance Instance:FindFirstChild(string name, bool recursive = false)" & @CRLF & _
" Function Objects Instance:GetChildren()" & @CRLF & _
" Function string Instance:GetDebugId(int scopeLength = 4) [notbrowsable] [PluginSecurity]" & @CRLF & _
" Function string Instance:GetFullName()" & @CRLF & _
" Function bool Instance:IsA(string className)" & @CRLF & _
" Function bool Instance:IsAncestorOf(Instance descendant)" & @CRLF & _
" Function bool Instance:IsDescendantOf(Instance ancestor)" & @CRLF & _
" Function void Instance:Remove() [deprecated]" & @CRLF & _
" Function Objects Instance:children() [deprecated]" & @CRLF & _
" Function Instance Instance:clone() [deprecated]" & @CRLF & _
" Function void Instance:destroy() [deprecated]" & @CRLF & _
" Function Instance Instance:findFirstChild(string name, bool recursive = false) [deprecated]" & @CRLF & _
" Function Objects Instance:getChildren() [deprecated]" & @CRLF & _
" Function bool Instance:isA(string className) [deprecated]" & @CRLF & _
" Function bool Instance:isDescendantOf(Instance ancestor) [deprecated]" & @CRLF & _
" Function void Instance:remove() [deprecated]" & @CRLF & _
" YieldFunction Instance Instance:WaitForChild(string childName)" & @CRLF & _
" Event Instance.AncestryChanged(Instance child, Instance parent)" & @CRLF & _
" Event Instance.Changed(Property property)" & @CRLF & _
" Event Instance.ChildAdded(Instance child)" & @CRLF & _
" Event Instance.ChildRemoved(Instance child)" & @CRLF & _
" Event Instance.DescendantAdded(Instance descendant)" & @CRLF & _
" Event Instance.DescendantRemoving(Instance descendant)" & @CRLF & _
" Event Instance.childAdded(Instance child) [deprecated]" & @CRLF & _
"Class Accoutrement : Instance" & @CRLF & _
" Property Vector3 Accoutrement.AttachmentForward" & @CRLF & _
" Property CoordinateFrame Accoutrement.AttachmentPoint" & @CRLF & _
" Property Vector3 Accoutrement.AttachmentPos" & @CRLF & _
" Property Vector3 Accoutrement.AttachmentRight" & @CRLF & _
" Property Vector3 Accoutrement.AttachmentUp" & @CRLF & _
"Class Hat : Accoutrement" & @CRLF & _
"Class AdService : Instance [notCreatable]" & @CRLF & _
" Function void AdService:ShowVideoAd()" & @CRLF & _
" Event AdService.VideoAdClosed()" & @CRLF & _
"Class AdvancedDragger : Instance" & @CRLF & _
"Class Animation : Instance" & @CRLF & _
" Property Content Animation.AnimationId" & @CRLF & _
"Class AnimationController : Instance" & @CRLF & _
" Function Array AnimationController:GetPlayingAnimationTracks()" & @CRLF & _
" Function Instance AnimationController:LoadAnimation(Instance animation)" & @CRLF & _
" Event AnimationController.AnimationPlayed(Instance animationTrack)" & @CRLF & _
"Class AnimationTrack : Instance" & @CRLF & _
" Property Object AnimationTrack.Animation [readonly]" & @CRLF & _
" Property bool AnimationTrack.IsPlaying [readonly]" & @CRLF & _
" Property float AnimationTrack.Length [readonly]" & @CRLF & _
" Property AnimationPriority AnimationTrack.Priority" & @CRLF & _
" Property float AnimationTrack.TimePosition" & @CRLF & _
" Function void AnimationTrack:AdjustSpeed(float speed = 1)" & @CRLF & _
" Function void AnimationTrack:AdjustWeight(float weight = 1, float fadeTime = 0.100000001)" & @CRLF & _
" Function double AnimationTrack:GetTimeOfKeyframe(string keyframeName)" & @CRLF & _
" Function void AnimationTrack:Play(float fadeTime = 0.100000001, float weight = 1, float speed = 1)" & @CRLF & _
" Function void AnimationTrack:Stop(float fadeTime = 0.100000001)" & @CRLF & _
" Event AnimationTrack.KeyframeReached(string keyframeName)" & @CRLF & _
" Event AnimationTrack.Stopped() [deprecated]" & @CRLF & _
"Class AnimationTrackState : Instance" & @CRLF & _
"Class Animator : Instance" & @CRLF & _
" Function Instance Animator:LoadAnimation(Instance animation)" & @CRLF & _
"Class AssetService : Instance" & @CRLF & _
" Function void AssetService:SetAssetRevertUrl(string revertUrl) [LocalUserSecurity]" & @CRLF & _
" Function void AssetService:SetAssetVersionsUrl(string versionsUrl) [LocalUserSecurity]" & @CRLF & _
" Function void AssetService:SetPlaceAccessUrl(string accessUrl) [LocalUserSecurity]" & @CRLF & _
" YieldFunction int AssetService:CreatePlaceAsync(string placeName, int templatePlaceID, string description = )" & @CRLF & _
" YieldFunction int AssetService:CreatePlaceInPlayerInventoryAsync(Instance player, string placeName, int templatePlaceID, string description = )" & @CRLF & _
" YieldFunction Dictionary AssetService:GetAssetVersions(int placeId, int pageNum = 1)" & @CRLF & _
" YieldFunction int AssetService:GetCreatorAssetID(int creationID)" & @CRLF & _
" YieldFunction Instance AssetService:GetGamePlacesAsync()" & @CRLF & _
" YieldFunction Dictionary AssetService:GetPlacePermissions(int placeId)" & @CRLF & _
" YieldFunction bool AssetService:RevertAsset(int placeId, int versionNumber)" & @CRLF & _
" YieldFunction void AssetService:SavePlaceAsync()" & @CRLF & _
" YieldFunction bool AssetService:SetPlacePermissions(int placeId, AccessType accessType = Everyone, Array inviteList = {})" & @CRLF & _
"Class BadgeService : Instance [notCreatable]" & @CRLF & _
" Function void BadgeService:SetAwardBadgeUrl(string url) [LocalUserSecurity]" & @CRLF & _
" Function void BadgeService:SetHasBadgeCooldown(int seconds) [LocalUserSecurity]" & @CRLF & _
" Function void BadgeService:SetHasBadgeUrl(string url) [LocalUserSecurity]" & @CRLF & _
" Function void BadgeService:SetIsBadgeDisabledUrl(string url) [LocalUserSecurity]" & @CRLF & _
" Function void BadgeService:SetIsBadgeLegalUrl(string url) [LocalUserSecurity]" & @CRLF & _
" Function void BadgeService:SetPlaceId(int placeId) [LocalUserSecurity]" & @CRLF & _
" YieldFunction bool BadgeService:AwardBadge(int userId, int badgeId)" & @CRLF & _
" YieldFunction bool BadgeService:IsDisabled(int badgeId)" & @CRLF & _
" YieldFunction bool BadgeService:IsLegal(int badgeId)" & @CRLF & _
" YieldFunction bool BadgeService:UserHasBadge(int userId, int badgeId)" & @CRLF & _
" Event BadgeService.BadgeAwarded(string message, int userId, int badgeId) [RobloxScriptSecurity]" & @CRLF & _
"Class BasePlayerGui : Instance" & @CRLF & _
"Class CoreGui : BasePlayerGui [notbrowsable] [notCreatable]" & @CRLF & _
" Property Object CoreGui.SelectionImageObject [RobloxScriptSecurity]" & @CRLF & _
" Property int CoreGui.Version [readonly]" & @CRLF & _
"Class PlayerGui : BasePlayerGui [notCreatable]" & @CRLF & _
" Property Object PlayerGui.SelectionImageObject" & @CRLF & _
" Function float PlayerGui:GetTopbarTransparency()" & @CRLF & _
" Function void PlayerGui:SetTopbarTransparency(float transparency)" & @CRLF & _
" Event PlayerGui.TopbarTransparencyChangedSignal(float transparency)" & @CRLF & _
"Class StarterGui : BasePlayerGui" & @CRLF & _
" Property bool StarterGui.ResetPlayerGuiOnSpawn" & @CRLF & _
" Property bool StarterGui.ShowDevelopmentGui" & @CRLF & _
" Function bool StarterGui:GetCoreGuiEnabled(CoreGuiType coreGuiType)" & @CRLF & _
" Function void StarterGui:RegisterGetCore(string parameterName, Function getFunction) [RobloxScriptSecurity]" & @CRLF & _
" Function void StarterGui:RegisterSetCore(string parameterName, Function setFunction) [RobloxScriptSecurity]" & @CRLF & _
" Function void StarterGui:SetCore(string parameterName, Variant value)" & @CRLF & _
" Function void StarterGui:SetCoreGuiEnabled(CoreGuiType coreGuiType, bool enabled)" & @CRLF & _
" YieldFunction Variant StarterGui:GetCore(string parameterName)" & @CRLF & _
" Event StarterGui.CoreGuiChangedSignal(CoreGuiType coreGuiType, bool enabled) [RobloxScriptSecurity]" & @CRLF & _
"Class BinaryStringValue : Instance" & @CRLF & _
"Class BindableEvent : Instance" & @CRLF & _
" Function void BindableEvent:Fire(Tuple arguments)" & @CRLF & _
" Event BindableEvent.Event(Tuple arguments)" & @CRLF & _
"Class BindableFunction : Instance" & @CRLF & _
" YieldFunction Tuple BindableFunction:Invoke(Tuple arguments)" & @CRLF & _
" Callback Tuple BindableFunction.OnInvoke(Tuple arguments)" & @CRLF & _
"Class BodyMover : Instance" & @CRLF & _
"Class BodyAngularVelocity : BodyMover" & @CRLF & _
" Property Vector3 BodyAngularVelocity.AngularVelocity" & @CRLF & _
" Property Vector3 BodyAngularVelocity.MaxTorque" & @CRLF & _
" Property float BodyAngularVelocity.P" & @CRLF & _
" Property Vector3 BodyAngularVelocity.angularvelocity" & @CRLF & _
" Property Vector3 BodyAngularVelocity.maxTorque" & @CRLF & _
"Class BodyForce : BodyMover" & @CRLF & _
" Property Vector3 BodyForce.Force" & @CRLF & _
" Property Vector3 BodyForce.force" & @CRLF & _
"Class BodyGyro : BodyMover" & @CRLF & _
" Property CoordinateFrame BodyGyro.CFrame" & @CRLF & _
" Property float BodyGyro.D" & @CRLF & _
" Property Vector3 BodyGyro.MaxTorque" & @CRLF & _
" Property float BodyGyro.P" & @CRLF & _
" Property CoordinateFrame BodyGyro.cframe [deprecated]" & @CRLF & _
" Property Vector3 BodyGyro.maxTorque [deprecated]" & @CRLF & _
"Class BodyPosition : BodyMover" & @CRLF & _
" Property float BodyPosition.D" & @CRLF & _
" Property Vector3 BodyPosition.MaxForce" & @CRLF & _
" Property float BodyPosition.P" & @CRLF & _
" Property Vector3 BodyPosition.Position" & @CRLF & _
" Property Vector3 BodyPosition.maxForce [deprecated]" & @CRLF & _
" Property Vector3 BodyPosition.position [deprecated]" & @CRLF & _
" Function Vector3 BodyPosition:GetLastForce()" & @CRLF & _
" Function Vector3 BodyPosition:lastForce() [deprecated]" & @CRLF & _
" Event BodyPosition.ReachedTarget()" & @CRLF & _
"Class BodyThrust : BodyMover" & @CRLF & _
" Property Vector3 BodyThrust.Force" & @CRLF & _
" Property Vector3 BodyThrust.Location" & @CRLF & _
" Property Vector3 BodyThrust.force [deprecated]" & @CRLF & _
" Property Vector3 BodyThrust.location [deprecated]" & @CRLF & _
"Class BodyVelocity : BodyMover" & @CRLF & _
" Property Vector3 BodyVelocity.MaxForce" & @CRLF & _
" Property float BodyVelocity.P" & @CRLF & _
" Property Vector3 BodyVelocity.Velocity" & @CRLF & _
" Property Vector3 BodyVelocity.maxForce [deprecated]" & @CRLF & _
" Property Vector3 BodyVelocity.velocity [deprecated]" & @CRLF & _
" Function Vector3 BodyVelocity:GetLastForce()" & @CRLF & _
" Function Vector3 BodyVelocity:lastForce()" & @CRLF & _
"Class RocketPropulsion : BodyMover" & @CRLF & _
" Property float RocketPropulsion.CartoonFactor" & @CRLF & _
" Property float RocketPropulsion.MaxSpeed" & @CRLF & _
" Property float RocketPropulsion.MaxThrust" & @CRLF & _
" Property Vector3 RocketPropulsion.MaxTorque" & @CRLF & _
" Property Object RocketPropulsion.Target" & @CRLF & _
" Property Vector3 RocketPropulsion.TargetOffset" & @CRLF & _
" Property float RocketPropulsion.TargetRadius" & @CRLF & _
" Property float RocketPropulsion.ThrustD" & @CRLF & _
" Property float RocketPropulsion.ThrustP" & @CRLF & _
" Property float RocketPropulsion.TurnD" & @CRLF & _
" Property float RocketPropulsion.TurnP" & @CRLF & _
" Function void RocketPropulsion:Abort()" & @CRLF & _
" Function void RocketPropulsion:Fire()" & @CRLF & _
" Function void RocketPropulsion:fire() [deprecated]" & @CRLF & _
" Event RocketPropulsion.ReachedTarget()" & @CRLF & _
"Class Test : Testing [readonly] [RobloxPlaceSecurity]" & @CRLF & _
" Property bool Testing.ReadOnlyAndSecure [readonly] [RobloxPlaceSecurity]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")