$re = '/Article\s[0-9]+(?![(0-9])/';
$str = 'Article 29
Article 30(1)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);