$re = '/^(202[01])[0-9]{4}abc\.(dat|csv)$/m';
$str = '01990205abc.dat
20200304abc.dat
20210506abc.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);