#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(-----BEGIN PUBLIC KEY-----(\n|\r|\r\n)([0-9a-zA-Z\+\/=]{64}(\n|\r|\r\n))*([0-9a-zA-Z\+\/=]{1,63}(\n|\r|\r\n))?-----END PUBLIC KEY-----)|(-----BEGIN PRIVATE KEY-----(\n|\r|\r\n)([0-9a-zA-Z\+\/=]{64}(\n|\r|\r\n))*([0-9a-zA-Z\+\/=]{1,63}(\n|\r|\r\n))?-----END PRIVATE KEY-----)"
Local $sString = "-----BEGIN PRIVATE KEY-----" & @CRLF & _
"MIICIjANBgkqhkiG9w0BAQEFAAOCAg8AMIICCgKCAgEAwghnvMu5YfnbprpLX105" & @CRLF & _
"SGuanX7zF+4mgNqozyFB7UsIha3ztQIYydrLc7pKXK7vQWWlqLUn0JW1vlAiTs2A" & @CRLF & _
"O+wdaFaEwKTNk1+mobGlpKUrzJEy24cnGV9XxNnh+WuxR7TicEpzNOdmDnSUaFMk" & @CRLF & _
"MdfpDXKKXfu/HJrADYuMq7VckEBR1yOBXVREDYpS8YvA85Kw04VAPVzxOHU7qdTR" & @CRLF & _
"hUPUD1rY3nKYJj33P0EW1e53xqeXZiiW6p3yi04X+OQscylMnfvxsG8tK18Qgi30" & @CRLF & _
"cQmny3yYGocKpfG7679Jy5EnkchqoC9L72Ust8A6s0WZVAe/bZxs5J5QEDdAkgAi" & @CRLF & _
"Miw84vWIHj2cuwgNKzBJHZ1uHmFrM8rkJWBvLyTRvS1pgn/yjQ4evOTH/yVTGnyM" & @CRLF & _
"BOSwrXmFbt4KXzXwtXIf0wllf2HZ3CwhB9g86ijPjvvgXn8eUbBEN12c/MePf3l1" & @CRLF & _
"doECe6oavsthqpk77IuFC6Yuy5ck0fkcHT2cw/U6hUBdTbuXs4/i7gMLE9VpjiDh" & @CRLF & _
"lYoMCYmuCR8Vn/G5gMQ4NbMjyvZY/d5U8tvktsC2ImQefuWu8vi/PGvDIdhq3TTz" & @CRLF & _
"sswoxcLxyqq0vjOnBmpMpua2PpLlZrSuBkuKIuZnxAiRkkLamAVH6SylYwmWvvam" & @CRLF & _
"ssssss1" & @CRLF & _
"-----END PRIVATE KEY-----" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"-----BEGIN PUBLIC KEY-----" & @CRLF & _
"MIICIjANBgkqhkiG9w0BAQEFAAOCAg8AMIICCgKCAgEAwghnvMu5YfnbprpLX105" & @CRLF & _
"SGuanX7zF+4mgNqozyFB7UsIha3ztQIYydrLc7pKXK7vQWWlqLUn0JW1vlAiTs2A" & @CRLF & _
"O+wdaFaEwKTNk1+mobGlpKUrzJEy24cnGV9XxNnh+WuxR7TicEpzNOdmDnSUaFMk" & @CRLF & _
"MdfpDXKKXfu/HJrADYuMq7VckEBR1yOBXVREDYpS8YvA85Kw04VAPVzxOHU7qdTR" & @CRLF & _
"hUPUD1rY3nKYJj33P0EW1e53xqeXZiiW6p3yi04X+OQscylMnfvxsG8tK18Qgi30" & @CRLF & _
"cQmny3yYGocKpfG7679Jy5EnkchqoC9L72Ust8A6s0WZVAe/bZxs5J5QEDdAkgAi" & @CRLF & _
"Miw84vWIHj2cuwgNKzBJHZ1uHmFrM8rkJWBvLyTRvS1pgn/yjQ4evOTH/yVTGnyM" & @CRLF & _
"BOSwrXmFbt4KXzXwtXIf0wllf2HZ3CwhB9g86ijPjvvgXn8eUbBEN12c/MePf3l1" & @CRLF & _
"doECe6oavsthqpk77IuFC6Yuy5ck0fkcHT2cw/U6hUBdTbuXs4/i7gMLE9VpjiDh" & @CRLF & _
"lYoMCYmuCR8Vn/G5gMQ4NbMjyvZY/d5U8tvktsC2ImQefuWu8vi/PGvDIdhq3TTz" & @CRLF & _
"sswoxcLxyqq0vjOnBmpMpua2PpLlZrSuBkuKIuZnxAiRkkLamAVH6SylYwmWvvam" & @CRLF & _
"ssssssqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqqs" & @CRLF & _
"-----END PUBLIC KEY-----"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")