const regex = /(\d{4})(\d{2})(\d{3})(\d{4})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4})(\\d{2})(\\d{3})(\\d{4})', '')
const str = `2520991515701`;
const subst = `\1-\2-\3-\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);