re = /(\w+\.(?:gif|png|jpe?g))/mi
str = 'Hello world

This is a test
adding text
Adding another image



'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end