$re = '/^.* To:\r?\n(.+)/m';
$str = 'INVOICE DETAILS Invoice To:
SOME ANALYTICS
Invoice# : R0264
Invoice Date: 27/06/20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);