using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=HTTP\/1.0""\s)(301)(?=\s5024)";
string input = @"11.22.33.44 - - [17/Aug/2019:11:24:01 -0400] ""GET /posts/posts/explore HTTP/1.0"" 301 5024 ""http://www.someurl.blah/faq.php"" ""Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_12_5) AppleWebKit/5310 (KHTML, like Gecko) Chrome/29.0.801.0 Safari/5310""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}