const regex = /<img\s+[^>]*?src=["\']?([^"\'> ]+)["\']?[^>]*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img\\s+[^>]*?src=["\\\']?([^"\\\'> ]+)["\\\']?[^>]*>', 'gm')
const str = `<!-- works -->
<div><img class="img-responsive" src="/images/dir%20with%20spaces/file%20with%20spaces.png?ver=1.0" /></div>
<div><img class="img-responsive" src="/images/dir/file-with-accents-áépi.png?ver=1.0" /></div>
<div><img class="img-responsive" src=unquotedimage.jpg /></div>
<div><img class="img-responsive" src=unquotedimagewithdoublequote".jpg /></div>
<div><img class="img-responsive" src=unquotedimagewithsinglequote'.jpg /></div>
<div><img class="img-responsive" src=unquotedimagewithcolon:.jpg /></div>
<!-- not working -->
<div><img class="img-responsive" src="/images/dir with spaces/file with spaces.png?ver=1.0" /></div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}