import re
regex = re.compile(r"\* \d+ FETCH \(UID \d+ BODY\[] {\d+}\s*([\s\S]*?)(?=\)[\r\n]+(?:\* \d+ FETCH \(UID \d+ BODY\[] {\d+}|SS01 OK Success))", flags=re.MULTILINE)
test_str = ("* 1 FETCH (UID 2 BODY[] {7765}\n"
"data to be extracted\n"
"from here!\n"
")\n"
"* 2 FETCH (UID 3 BODY[] {443}\n"
"data to be extracted\n"
"from here!\n"
")\n"
"* 3 FETCH (UID 4 BODY[] {4432}\n"
"data to be extracted\n"
"from here!\n"
")\n"
"* 4 FETCH (UID 5 BODY[] {123}\n"
"data to be extracted\n"
"from here!\n"
")\n"
"SS01 OK Success")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")