package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<img(.*)src="(.*)"(.*)width=(.*)>`)
var str = `<iframe src="somepage.html width="500" height="100"></iframe>
<div id="attachment_608427" class="wp-caption alignnone" style="width: 1210px"><img class="size-full wp-image-608427" alt="031 КвеÑÑ‚ «Как не потерÑтьÑÑ Ð² квеÑтах»: 10 преимущеÑтв ExitGames" src="http://bigpicture.ru/cdn/wp-content/uploads/2015/03/031.jpg" width="1200" height="800" title="КвеÑÑ‚ «Как не потерÑтьÑÑ Ð² квеÑтах»: 10 преимущеÑтв ExitGames" /><p class="wp-caption-text">3. <strong>Первый и Ñамый крупный игровой центр МоÑквы.</strong><br /> Площадь игровой зоны ExitGames — более 1000 кв. м, Ñто позволÑет размеÑтить более 22 поÑтоÑнно дейÑтвующих игровых комнат. ФактичеÑки, когда бы вы ни приехали в центр и в каком ÑоÑтаве — вы Ñможете Ñразу приÑтупить к игре. Единовременно ÑÐµÐ³Ð¾Ð´Ð½Ñ Ð¼Ð¾Ð³ÑƒÑ‚ играть до 40 человек, а Ñто уже корпоратив <img src='http://bigpicture.ru/cdn/wp-includes/images/smilies/icon_wink.gif' alt="icon wink КвеÑÑ‚ «Как не потерÑтьÑÑ Ð² квеÑтах»: 10 преимущеÑтв ExitGames" class='wp-smiley' title="КвеÑÑ‚ «Как не потерÑтьÑÑ Ð² квеÑтах»: 10 преимущеÑтв ExitGames" /></div>
<img src="test.jpg" width="" height="" />
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}