$re = '/^([a-zA-Z]:(?:\\\\[^\\\\\n]+)*)\((\d+)\) error/m';
$str = 'C:\\projekte\\privat\\freebasic\\test.bas(24) error 3: Expected End-of-Line, found ...
C:\\projekte\\privat\\freebasic\\test.bas(25) error 41: Variable not declared, This ....
C:\\projekte\\privat\\freebasic\\test.bas(26) error 9: Expected expression, found ...
C:\\projekte\\privat\\freebasic\\test.bas(27) error 9: Expected expression, found ...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);