const regex = /<img alt=\\"(http[^"]*)\\".*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img alt=\\\\"(http[^"]*)\\\\".*', '')
const str = `<img alt=\\"http://www.adsf1.net/static/1231.jpg\\" width=\\"100%\\">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}