#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(^(post|merge|delete)\s(\/WcfDataService1\.svc\/)(.*)(HTTP\/1\.1)([\s]*)($|^{.*}))"
Local $sString = "--batchitems" & @CRLF & _
"Content-Type: application/http" & @CRLF & _
"Content-Transfer-Encoding: binary" & @CRLF & _
"" & @CRLF & _
"POST /WcfDataService1.svc/Orders(123) HTTP/1.1" & @CRLF & _
"" & @CRLF & _
"{Order: 58}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")