$re = '/(?:\G(\d[a-zA-Z]+,?)| ([A-Z]+))/m';
$str = '1a,1b,1c ABC
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);