package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\S+(?:\s&\s\S+)*`)
var str = `H & M shopping mall`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}