re = /(https?:\/\/)?([\da-z\.-]+)(\.[a-z\.]{2,6})([\/\w \.-]*)/
str = '<table style="width:90%"><tr ><td width="16%"><a href="https://treasury8.aspac.citigroup.net/APCB/cust_cashplus_rates_IPBSG.jsp" target="_blank"><img alt="" src="images/FCYtimedeposit_button.JPG" width="53px" border="0"/></a></td>
<td width="34%" align="left"><a href="https://treasury8.aspac.citigroup.net/APCB/cust_cashplus_rates_IPBSG.jsp" target="_blank" > <strong>FCY TD Customer Rates</strong></a></td>
<td width="16%"><a href="https://knowledgemanagement.apac.nsroot.net/sites/gcg/intra2/rates/Lists/Rates%20and%20Commentaries/LTD%20Preference%20Rates.aspx" target="_blank"><img alt="" src="images/SGDtimedeposit_button.JPG" width="53px" border="0"/></a></td>
<td width="34%" align="left"><a href="https://knowledgemanagement.apac.nsroot.net/sites/gcg/intra2/rates/Lists/Rates%20and%20Commentaries/LTD%20Preference%20Rates.aspx" target="_blank" > <strong>SGD TD Customer Rates</strong></a></td>
</tr>
<tr ><td width="16%"><a href="https://treasury8.aspac.citigroup.net/APCB/treasury_interest_rates.jsp" target="_blank"><img alt="" src="images/FCYinterbranch_button.JPG" width="53px" border="0"/></a></td>
<td width="34%" align="left"><a href="https://treasury8.aspac.citigroup.net/APCB/treasury_interest_rates.jsp" target="_blank" > <strong>FCY Inter-branch Rates</strong></a></td>
<td width="16%"><a href="../../USR23/InvestFinance/BenchmarkRates/Benchmark%20Rates.doc" target="_blank"><img alt="" src="images/USDprimerate_button.JPG" width="53px" border="0"/></a></td>
<td width="34%" align="left"><a href="../../USR23/InvestFinance/BenchmarkRates/Benchmark%20Rates.doc" target="_blank" > <strong>US$ Prime Rate</strong></a></td>
</tr>
<tr ><td width="16%"><a href="https://knowledgemanagement.apac.nsroot.net/sites/gcg/Intra2/rates/Lists/Rates%20and%20Commentaries/SGD%20Interbank%20Rates.aspx" target="_blank"><img alt="" src="images/SGDinterbank_button.JPG" width="53px" border="0"/></a></td>
<td width="34%" align="left"><a href="https://knowledgemanagement.apac.nsroot.net/sites/gcg/Intra2/rates/Lists/Rates%20and%20Commentaries/SGD%20Interbank%20Rates.aspx" target="_blank" > <strong>SGD Inter-Bank Rates</strong></a></td>
<td width="16%"><a href="https://treasury8.aspac.citigroup.net/APCB/Customer_FX_Rates_SG.jsp" target="_blank"><img alt="" src="images/APCBfxcounterrates_button.JPG" width="53px" border="0"/></a></td>
<td width="34%" align="left"><a href="https://treasury8.aspac.citigroup.net/APCB/Customer_FX_Rates_SG.jsp" target="_blank" > <strong>APCB FX Counter Rates</strong></a></td>
</tr>
</table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end