# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<Beleg>[A-Z,0-9]{5,6}).(?<Kontierung>[0-9]{3,5}.[0-9]{3}.[0-9]{2}-[0-9]{2}).(?<Datum>[0-9]{2}.[0-1]{1}[0-9]{1}.[0-9]{2}).(?<VS>[0-9]{3}).(?<US>[0-9]{3})?.(?<UmsatzSoSpace>.?.?.?.?.?.?.?.?.?.?.?.?.?.?.?.?.?)(?<UmsatzSo>[0-9]{0,1}?[0-9]{0,1}?.?[0-9]{0,3}?.?[0-9]{0,3}?.?[0-9]{0,3}?.?[0-9]{0,1}?[0-9]{0,1}?[0-9]{1}?,[0-9]{2}).(?<UmsatzHaSpace>.?.?.?.?.?.?.?.?.?.?.?.?.?.?.?.?)(?<UmsatzHa>[0-9]{0,1}?.?[0-9]{0,3}?.?[0-9]{0,3}?.?[0-9]{0,3}?.?[0-9]{0,1}?[0-9]{0,1}?[0-9]{1}?,[0-9]{2}).(?<GK>[0-9]{2}).(?<Buchungstext>[(\w)(\W)(\s)]{53}).(?<MwSt>[0-9]{0,4}).(?<E_Nr>[0-9]{5})"
test_str = "TA9876 10648.000.69-99 04.04.99 999 445,00 0,00 01 Hausgeld WE 23 HAUSG. 19 17847"
matches = re.search(regex, test_str, re.MULTILINE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.