import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([ \\t]*)</head";
final String string = "<!DOCTYPE html><html class=\"no-js\" lang=\"es-ES\"><head> <meta charset=\"utf-8\" /> <meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0\" /> <title></title> <meta name=\"description\" content=\"blog de programación\"/> <meta property=\"og:locale\" content=\"es_ES\" /> <meta property=\"og:type\" content=\"website\" /> <meta property=\"og:title\" content=\"\" /> <meta property=\"og:description\" content=\"blog de programación\" /> <meta property=\"og:url\" content=\"\" /> <meta property=\"og:site_name\" content=\"\" /> <meta name=\"robots\" content=\"index, follow\" /> <!-- This site is being optimized with the Bob Bolt SEO Premium Extension™ v0.9.7 Platinum Edition Pro. --> </head><body><div class=\"row\" id=\"head\"> <section id=\"web\"> </section></div> <script src=\"/bolt-public/view/js/jquery-1.11.2.min.js\"></script>\n"
+ " <script src=\"https://cdn.rawgit.com/google/code-prettify/master/loader/run_prettify.js?skin=sons-of-obsidian\"></script><script type=\"text/javascript\" src=\"/js/main.1445862200.js\"></script></body></html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}