import re
regex = re.compile(r"@{{(?P<id>TAGS|[ -~]+?):(?:(?P<attr>DATADIR|TAGSFILE|RESULT_INT)|(?P<expr>[ -~]+?))}}@")
test_str = "@{{TAGS:sTagsJob << \"job||ID||source\"}}@ test @{{job:DATADIR}}@ email body @{{job:DATADIR}}@ blah @{{TAGS:sTagsJob << \"job||ID||source\"}}@ test @{{job:DATADIR}}@ email body @{{job:DATADIR}}@ blah @{{TAGS:sTagsJob << \"job||ID||source\"}}@ test @{{job:DATADIR}}@ email body @{{job:DATADIR}}@ blah @{{TAGS:sTagsJob << \"job||ID||source\"}}@ test @{{job:DATADIR}}@ email body @{{job:DATADIR}}@ blah"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")